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Appendix 1 - Pajek

2.1 Installation

Pajek software for network analysis can be installed on all computers operating

under Windows 95, 98, 2000, or NT. The software must be installed on the

computer’s hard disk. Double-click the file named Pajek.be.exe (Pajek book

edition) and follow the instructions.

After completion of the installation procedure, Pajek can be started by

double-clicking the file Pajek.exe which you will find in the directory where

you installed the program. This directory contains additional information about

the software in several hypertext files (.htm), which can be opened in an internet

browser, and Portable Document Files (.pdf), which can be read with (Adobe)

Acrobat Reader.

2.2 Data formats

Pajek can read network data in several plain text formats, that is, files containing

unformatted text (ASCII). We will briefly discuss them in the order in which they

appear on the dialog box issued by the File>Network>Read command (Figure 1).

Figure 1 - Read Network dialog box.

The first two data formats are indigenous Pajek formats: Pajek networks and

Pajek matrices. The Pajek network format (filename extension is .net)  is
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explained in Chapter 1 (Section 1.3.1) and additional features for longitudinal

networks are discussed in Chapter 4 (Section 4.5).

The Pajek matrix format (filename extension is .mat) is slightly different.

The list of vertices is the same as in the Pajek network format but the list of edges

and arcs is replaced by a matrix consisting of integers or real numbers which are

separated by blanks (Figure 2). This is an ordinary adjacency matrix (see Chapter

12, Section 12.2). The Pajek matrix format is very useful for importing network

data in matrix format from a variety of sources.
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*Vertices     6
    1 "Ada"                0.1646    0.2144    0.5000
    2 "Cora"               0.0481    0.3869    0.5000
    3 "Louise"             0.3472    0.1913    0.5000
    4 "Jean"               0.1063    0.5935    0.5000
    5 "Helen"              0.2892    0.6688    0.5000
    6 "Martha"             0.4630    0.5179    0.5000
*Matrix
0.000 1.000 1.000 0.000 0.000 0.000
1.000 0.000 0.000 1.000 0.000 0.000
0.000 0.000 0.000 0.000 0.000 0.000
0.000 0.000 0.000 0.000 1.000 0.000
0.000 0.000 0.000 1.000 0.000 0.000
0.000 0.000 0.000 0.000 0.000 0.000
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igure 2 - A network in Pajek matrix format.

he third data format is the Vega format devised by Pisanski. The fourth format –

EDCOM – is the standard data format for genealogical data, which is discussed

n Chapter 8 (Section 11.3, also see the section Further Reading). The fourth

ormat, UCINET DL files, is the raw data format of another widely used program

or network analysis: UCINET. Networks exported in this format can be read by

oth UCINET and Pajek, so this is a way to exchange data between the two

oftware packages. For more information about UCINET, consult the web site

ttp://www.analytictech.com/ucinet_5_description.htm.

The last three data formats (Ball and Stick, Mac Molecule, and MDL MOL)

riginated in chemistry. These formats are not widely used in social network

nalysis.

.3 Limitations

ajek can handle networks up to 999.997 vertices. In general, drawings of

etworks should not contain more than a few thousand vertices because the

rawing procedure is time-consuming and the drawing is visually unattractive for

ery large networks. By default, Pajek will not draw networks larger than 5,000

ertices but you can change this limit in the Options>Read/Write menu.

Available resources on the computer may pose additional limitations. It is

nown that the listing of results in the Report screen is sometimes restricted to a

http://eclectic.ss.uci.edu/~lin/ucinet.html
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maximum number of lines on a computer. In this case, delete (all) lines from the

Report screen which you do not want to save.

2.4 Updates of Pajek

Updates of Pajek can be downloaded from http://vlado.fmf.uni-

lj.si/pub/networks/pajek/default.htm. Due to modifications, newer versions of

Pajek may not match the illustrations, command names, and output described in

this book exactly.

http://vlado.fmf.uni-lj.si/pub/networks/pajek/default.htm
http://vlado.fmf.uni-lj.si/pub/networks/pajek/default.htm
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Appendix 2 - Exporting visualizations

In Chapter 1, several options for exporting graphical output are briefly discussed.

We will provide more details in this Appendix. In Section 2.1, we will list the

viewers needed to show the exported layout of a network. Next, we will discuss

the options to adjust the layout of the exported image (Section 2.2).

2.1 Viewers

Pajek can save a sociogram in six different graphical formats. Table 1

summarizes the most important information on these formats. Viewers and plug-

ins must be installed on your computer before you can display the exported

layout. Consult the file PajekMan.htm for more details on the various

commands to export Scalable Vector Graphics and Kinemages.

Table 1 - Graphic formats and viewers.

Format Characteristics Viewer Software for

manual editing

(Encapsulated)

Postscript (EPS/PS)

2D vector based

drawing for high

quality printing

GhostScript and GhostView

http://www.cs.wisc.edu/~gho

st/

dedicated drawing

software, such as

Adobe Illustrator or

Corel Draw

Scalable Vector

Graphics (SVG)

2D interactive

representation for the

world wide web

web browser and SVG plug-

in

http://www.adobe.com/svg/v

iewer/install/

Webdraw

http://www.jasc.com

/products/webdraw/

Virtual Reality

Modeling Language

(VRML)

3D interactive

representation for the

world wide web

web browser and plug-in:

Cosmo player

(http://www.cai.com/cosmo/

home.htm) or Cortona

(http://www.parallelgraphics.

com/products/downloads)

check

(http://www.web3d.

org/vrml/wb31.htm)

for VRML design

and editing software

MDL MOL file 3D representation of

the network as a

molecule

web browser and Chemscape

Chime plug-in

http://www.mdli.com/

Kinemages animated sequences of

images to which text

can be added

Mage viewer

http://www.prosci.org/Kinem

age/MageSoftware.html

Bitmap pixel based image of

the sociogram exactly

as it is shown in the

Draw screen

can be embedded in most

Windows word processors

and database software

any Windows paint

program

2.2 Layout options

PostScript, SVG, and VRML visualizations need additional information about the

size, placement, and colors of vertices, lines, labels, and background. This

http://www.cs.wisc.edu/~ghost/
http://www.cs.wisc.edu/~ghost/
http://www.adobe.com/svg/viewer/install/
http://www.adobe.com/svg/viewer/install/
http://www.jasc.com/products/webdraw/
http://www.jasc.com/products/webdraw/
http://www.cai.com/cosmo/home.htm
http://www.cai.com/cosmo/home.htm
http://www.parallelgraphics.com/products/downloads
http://www.parallelgraphics.com/products/downloads
http://www.web3d.org/vrml/wb31.htm
http://www.web3d.org/vrml/wb31.htm
http://www.mdli.com/
http://www.prosci.org/Kinemage/MageSoftware.html
http://www.prosci.org/Kinemage/MageSoftware.html
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information can be supplied with the Options command in the Export menu of the

Draw screen.

Figure 3 - The Options screen.

The Export>Options command opens a window which is divided into 5 frames,

two on the left and three on the right (Figure 3). We will discuss each frame

separately, but we should note first that the settings in this window will only

modify the exported visualizations if they are not set in the Pajek network file. If,

for instance, the color of vertices is specified in the network data file, entering a

color in the Options window has no effect.

If you want to save the settings of a particular layout, use the Options>Ini

File>Save command in the Main screen. This command saves all present settings

to a file, which can be loaded (command Options>Ini File>Load) to restore the

settings.

2.2.1 Top frame on the left - EPS/SVG Vertex Default

This frame defines how vertices are drawn when we export 2D layouts to

(Encapsulated) PostScript and Scalable Vector Graphics. Figure 4 shows some

important properties of the layout of a vertex and its label.

Figure 4 - Layout of a vertex and its label.

In the top frame, the color of the interior (Interior Color) and border (Border

Color) of the vertices can be specified. Enter one of the colors which are listed in

V1

0º (label position: angle)

0º (label angle)

border

label position: radius

interior
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Figure 6 and make sure you use upper and lower case letters as specified in this

figure. The width of the border (Border Width) and the shape of the vertex

(Shape) can be defined. The user may choose among the predefined shapes

ellipse, box, and diamond and s/he may ‘squeeze’ or ‘stretch’ the shape

horizontally by adjusting the x/y ratio (x/y Ratio). If this ratio is smaller than one,

the shape of the vertex is squeezed, if it is larger than one, it is stretched. In

Figure 5, the horizontal diameter of the vertex on the left is half the vertical

diameter, so it’s x/y ratio is 0.5. The horizontal diameter of the other vertex is 50

percent longer than the vertical diameter.

Figure 5 - The x/y ratio of a vertex.

Figure 6 - Colors in Pajek.

The color (Label Color) and font size (Font Size) of the label can also be

adjusted in this frame. Again, use names of colors as listed in Figure 6. In

addition, the orientation of the vertex label (Label Angle) can be changed

relative to a horizontal line. Zero degrees is usually the best choice because this

will display the labels horizontally. Label angles from 360 to 720 degrees

GreenYellow

Yellow

Goldenrod

Dandelion

Apricot

Peach

Melon

YellowOrange

Orange

BurntOrange

Bittersweet

RedOrange

Mahogany

Maroon

BrickRed

Red

OrangeRed

RubineRed

WildStrawberry

Salmon

CarnationPink

Magenta

VioletRed

Rhodamine

Mulberry

RedViolet

Fuchsia

Lavender

Thistle

Orchid

DarkOrchid

Purple

Plum

Violet

RoyalPurple

BlueViolet

Periwinkle

CadetBlue

CornflowerBlue

MidnightBlue

NavyBlue

RoyalBlue

Blue

Cerulean

Cyan

ProcessBlue

SkyBlue
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TealBlue

Aquamarine

BlueGreen

Emerald

JungleGreen

SeaGreen

Green

ForestGreen

PineGreen

LimeGreen

YellowGreen

SpringGreen

OliveGreen

RawSienna

Sepia

Brown

Tan

Gray

Black

White

LightYellow

LightCyan

LightMagenta

LightPurple

LightGreen

LightOrange

Canary

LFadedGreen

Pink

LSkyBlue

x/y ratio: 1.50.5
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position the label relative to the to center of the layout, which can be useful when

all vertices are drawn in concentric circles.

The most complicated part, however, is the position of the label with respect

to the vertex. The position of the label is defined by its distance to the center of

the vertex – the radius – and by the angle from the horizontal line starting at this

center, ranging from 0 to 360 degrees (Label Position: Radius/Angle). If the

angle of the label position is zero, the label is resting on this horizontal line at the

right of the vertex. If the radius is zero, the label is placed in the center of the

vertex. With short labels and large vertices (see 2.2.3) or high x/y ratio, the label

may fit inside the vertex. To place labels outside but near their vertices, enter a

positive number in the Label Position: Radius field. It is difficult to give a

general rule for a good size of the radius, because it depends on the size of the

vertex and the size of the label’s type font. Most figures of this book used the

sizes shown in Figure 3.

2.2.2 Bottom frame on the left - EPS/SVG Line Default

This frame defines the way the lines are drawn when 2D layouts are exported to

(Encapsulated) PostScript and Scalable Vector Graphics. It contains fields

defining the appearance of lines and line values or line labels as well as fields

which specify the orientation of labels and their location with respect to the lines

to which they belong.

The colors of edges (Edge Color), arcs (Arc Color) and labels (Label Color)

can be changed by entering names of colors as they appear in Figure 6. Note that

arcs and edges may receive different colors. You may draw all lines as dotted

lines by selecting Dots in the Pattern field. The width of edges (Edge Width)

and arcs (Arc Width) may also differ; it is good practice to draw edges a bit

wider than arcs. The size of the arrowhead (Arrow Size) is specified

independently of the arc’s width. The size of the labels is defined by their font

size (Fontsize), which should be smaller than the font size of the vertex labels for

pleasant results.

You may decide where to place the arrowhead on the line (Arrow Position).

A number between 0 and 1 is interpreted as a proportion expressing the relative

distance from the end to the beginning of the arc, e.g., 0 will place the arrowhead

at the end of the arc near the terminal vertex and 0.5 will situate the arrowhead in

the middle of the arc. A distance larger than 1 is interpreted as an absolute

distance from the terminal vertex. This is useful if you want to have all arcs on

the same distance from terminal vertex, regardless of the arc’s length. You have

to experiment a little to find a pleasing distance.

The remaining fields concern the orientation and position of the line label,

e.g., it’s value, with respect to the line. Figure 7 illustrates the relevant

parameters. First, the position on the line (edge or arc) must be chosen to which

the line label is attached (Label Position). This is similar to the position of the

arrowhead: numbers between 0 and 1 are proportions, that is, relative distances

from the end to the beginning of the line, and numbers above 1 are absolute
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distances from the end of the line. In Figure 7, the label position is 0.67, so it is

located at two thirds of the arc, measured from its end. Note that edges do not

have a start and an end, so it is most appropriate to position the edge labels

halfway.

Figure 7 - The position and orientation of a line label.

Next, the location of the center of the label with respect to the position on the line

is defined by two properties which are similar to the location of vertex labels:

radius and angle. The radius (Label Position: Radius) is the distance between

the position on the line and the center of the line label which is measured at the

specified angle (Label Position: Angle) from the line. In Figure 7, the angle is

270 degrees.

Finally, the orientation of the line label is defined in the Label Angle field.

An angle smaller than 360 degrees is measured relative to the direction of the

line, where 0 degree is parallel to the line. Angles of 360 degrees and more are

relative to a horizontal line. For easy reading, an angle of 360 degrees is optimal

because it displays line labels horizontally.

2.2.3 Top frame on the right

This frame defines additional defaults when we export layouts to Virtual Reality

Modeling Language (VRML). The field EPS, SVG, VRML Size of Vertices

specifies the default size of vertices when exporting to VRML but also to EPS

and SVG. The diameter of lines in VRML can be changed in the VRML Size of

Lines field. It is difficult to give general rules about optimal settings for these

fields; you have to experiment.

In the VRML Bckg. Color field, finally, you can choose a background color

for the layout in VRML: just enter one of the color names listed in Figure 6.

2.2.4 Middle frame on the right

This frame defines additional properties of the network layout when we export

layouts to Encapsulated PostScript and Scalable Vector Graphic. Most fields

relate to a border around the layout. With the four fields Right, Left, Top, and

1.6

0º (label position: angle)

0º (label angle relative to line)

label position: radius

terminal vertex

360º (label angle relative to page)

label position
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Bottom, you can add additional space to the right, left, etc. of the picture. This is

effective for SVG exports and for EPS exports when the EPS Clip format is

selected.

The color of the border (Border Color) as well as the background (Bckg.

Color) can be picked from the color names listed in Figure 6. Enter the word No

in these fields if you do not want a border or background color. The shape of the

borderline is characterized by the fields Border Radius and Border Width. If

the radius of the border is zero, the border is a rectangle. Higher values, e.g., 10,

50, or 100, round off the corners. A border width of one unit produces a rather

thin borderline and higher values yield a fatter borderlines.

Finally, this window contains a field in which a file can be selected with

custom shapes for vertices. The default is the file shapes.cfg. Defining custom

shapes demands knowledge of the PostScript language.

2.2.5 Bottom frame on the right - SVG Default

The last frame contains additional options for exporting Scalable Vector

Graphics. These layouts can handle gradient colors: an area in which one color

gradually blends into another color. You can specify three colors. The first color

is the background color defined in the middle frame (see Section 2.2.4). The

second color can be selected in the Bckg. Color 2 field. Use the color names of

Figure 6 and enter the word No if you do not want to use a second color, hence no

gradient. If you like, you can select a third color in the Bckg. Color 3 field. The

type of ‘blend’ can be selected in the Gradients field: Linear, or Radial (see

Figure 8). In a linear gradient color, the original background color is at the top of

the area blending into the second and third colors on its way down. The middle of

the drawing is painted by the original background color in a radial gradient.

Figure 8 also shows the effects of the 3D Effect on Vertices option.

Figure 8 - Gradients in SVG export: linear (left) and radial (right).
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